Version of Delve is too old for this version of Go 라고 에러가 뜰때…

API server listening at: 127.0.0.1:42081
Version of Delve is too old for this version of Go (maximum supported version 1.14, suppress this error with --check-go-version=false)
Process exiting with code: 1

간만에 VSCode로 Go 파일 빌드 걸었더니만 저렇게 뜸
VSCode는 꾸준히 업데이트 했고 golang은 업데이트 안해줘서 그런듯

go get -u github.com/go-delve/delve/cmd/dlv

터미널창에서 요러케 해주면 해결됨

 

 

관련해서 이래저래 검색해보고 폴더 보다가 알게된것인데 dlv나 기타 파일들이 sdk 업데이트 하면 같이 업데이트 되는건줄 알았는데 아니였음.
저 파일들은 golang 플젝 처음 시작하면 VSCode 에서 아래와 같이 알림팝업을 띄우면서 빌드 할래? 라고 물어보는데

내가 golang 플젝 처음(?) 할때 빌드해놓은 dlv.exe를 여태 쓰다가 이제 너무 오래 되서 위와 같은 문제가 발생한거였음.

위 스샷에서 Install All을 누르면 아래 목록파일들이 다운받아서 빌드됨

Installing 17 tools at C:\Develop\Projects\Go\bin in module mode.
  gocode
  gopkgs
  go-outline
  go-symbols
  guru
  gorename
  gotests
  gomodifytags
  impl
  fillstruct
  goplay
  godoctor
  dlv
  gocode-gomod
  godef
  goimports
  golint
크리에이티브 커먼즈 라이선스 Linsoo 의 저작물인 이 저작물은(는) 크리에이티브 커먼즈 저작자표시-동일조건변경허락 4.0 국제 라이선스 에 따라 이용할 수 있습니다.

댓글 남기기

이메일은 공개되지 않습니다.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.